Splunk Cookie Policy

We use our own and third-party cookies to provide you with a great online experience. We also use these cookies to improve our products and services, support our marketing campaigns, and advertise to you on our website and other websites. Some cookies may continue to collect information after you have left our website. Learn more (including how to update your settings) here.
Accept Cookie Policy

Accept License Agreements

This app is provided by a third party and your right to use the app is in accordance with the license provided by that third-party licensor. Splunk is not responsible for any third-party apps and does not provide any warranty or support. If you have any questions, complaints or claims with respect to this app, please contact the licensor directly.

Thank You

Downloading Technology Add-On for Mikrotik RouterOS
To install your download
For instructions specific to your download, click the Details tab after closing this window.

Flag As Inappropriate

Technology Add-On for Mikrotik RouterOS

Overview
Details
The Splunk Technology Add-On for Mikrotik RouterOS provides extractions and CIM normalization for Mikrotik RouterOS devices.
CIM data models network traffic, name resolution (DNS), DHCP and authentication are used.

Technology Add-On for Mikrotik RouterOS

The Splunk Technology Add-On for Mikrotik RouterOS provides extractions and CIM normalization for Mikrotik RouterOS devices.
CIM data models network traffic, name resolution (DNS), DHCP and authentication are used.

Activation of logging using Mikrotik RouterOS

To activate logging of RouterOS events activate Syslog logging. Use a Syslog server or activate a UDP input on Splunk Forwarder.

To activate logging use the CLI

  • create a logging action
    /system logging action
    add name=syslogbw remote=1.2.3.4 remote-port=5200 src-address=2.3.4.5 target=remote

  • create a logging profile
    /system logging
    set 0 topics=info,!firewall
    add action=syslog topics=info
    add action=syslog topics=warning
    add action=syslog topics=critical
    add action=syslog topics=error
    add action=syslog topics=dns,!debug

Firewall logging

You need to enable logging for every rule you want to analyse. To do so specify a rulename and an action. Action needs to be "drop" or "accept".
use "log=yes log-prefix="rulename drop|accept" when creating a rule.

Here is an example for a drop rule:
add action=drop chain=input connection-nat-state=!dstnat connection-state=new in-interface=ether1 log=yes log-prefix="input_wan drop"

This is an example for a forward rule:
add action=accept chain=forward dst-address=0.0.0.0/0 in-interface=mynet log=yes log-prefix="fwd_bw_internet accept" out-interface=ether1 src-address=192.168.1.0/24

Installation and Deployment of TA-routeros

Download this TA and place it in etc/apps on your Searchhead, Indexers and Universal Forwarders (Syslog servers).

Here is an example inputs.conf:

[monitor:///var/log/cases/routeros//.log]
index = batchworks
sourcetype = routeros
host_segment = 5
disabled = 0

Verify the data input and extraction works by searching for

sourcetype=routeros tag=network tag=communicate


Subscribe Share

Splunk Certification Program

Splunk's App Certification program uses a specific set of criteria to evaluate the level of quality, usability and security your app offers to its users. In addition, we evaluate the documentation and support you offer to your app's users.

Are you a developer?

As a Splunkbase app developer, you will have access to all Splunk development resources and receive a 50GB license to build an app that will help solve use cases for customers all over the world. Splunkbase has 1000+ apps and add-ons from Splunk, our partners and our community. Find an app or add-on for most any data source and user need, or simply create your own with help from our developer portal.

Follow Us:
© 2005-2018 Splunk Inc. All rights reserved.
Splunk®, Splunk>®, Listen to Your Data®, The Engine for Machine Data®, Hunk®, Splunk Cloud™, Splunk Light™, SPL™ and Splunk MINT™ are trademarks and registered trademarks of Splunk Inc. in the United States and other countries. All other brand names, product names, or trademarks belong to their respective owners.